import re
regex = re.compile(r"^(.+).+?(\S*?(?=\1)\S*?)$", flags=re.MULTILINE)
test_str = ("ABCD 19475ABCD_97jdhgbl\n"
"ABCD 19475ABC_97jdhgbl\n"
"CDEF 87437862AB83742kh")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")