const regex = /^(.+).+?(\S*?(?=\1)\S*?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+).+?(\\S*?(?=\\1)\\S*?)$', 'gm')
const str = `ABCD 19475ABCD_97jdhgbl
ABCD 19475ABC_97jdhgbl
CDEF 87437862AB83742kh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}