using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"goTo(_[\S_]+){3}";
string input = @"param-out goTo goTo_6f7aaaab-8a2b-4654-9a51-eb590ec0f2b4_1_ddb34756-8194-4e5a-8aa9-12a755eff6c1 goTo-1
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}