import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "goTo(_[\\S_]+){3}";
final String string = "param-out goTo goTo_6f7aaaab-8a2b-4654-9a51-eb590ec0f2b4_1_ddb34756-8194-4e5a-8aa9-12a755eff6c1 goTo-1\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}