package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^ #;\[]{77}$`)
var str = `lets_make_a_snake<-function(n)\`for\`(i,1:n,cat(i*n+1-\`if\`(i%%2,n:1,1:n),"\n"))
invisible(sapply(1:(n=scan()),function(i)cat(i*n+1-\`if\`(i%%2,n:1,1:n),"\n")))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}