import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[(?:[^[\\]]*?)\\]\\s*?(?=\\[))|(\\[(?:[^[\\]]*?)\\](?!\\s*[\\|&]\\s*.))|(?:\\[[^[\\]]*?])|([^&\\|\\s]+)\\s+(?=[^&\\|\\s]+)";
final String string = "[uname!uname] [uname!uname] | [submission_name !CustomValue] | [uname!uname] [submission_name!CustomValue] [uname> colin] 7 3&dsa | asf as d | [143 & t] | d d d";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}