using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=WIDTH.*?;).*?(\d+)";
string input = @"WIDTH: 700px; HEIGHT: 467px
HEIGHT: 467px WIDTH: 700px;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}