re = /(?=WIDTH.*?;).*?(\d+)/m
str = 'WIDTH: 700px; HEIGHT: 467px
HEIGHT: 467px WIDTH: 700px;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end