$re = '/(?=WIDTH.*?;).*?(\d+)/m';
$str = 'WIDTH: 700px; HEIGHT: 467px
HEIGHT: 467px WIDTH: 700px;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);