#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=[diomarf]).*f.*"
Local $sString = "amfora" & @CRLF & _
"difamador" & @CRLF & _
"difamar" & @CRLF & _
"dimorf" & @CRLF & _
"dofi" & @CRLF & _
"fada" & @CRLF & _
"far" & @CRLF & _
"farao" & @CRLF & _
"farda" & @CRLF & _
"fiar" & @CRLF & _
"fiord" & @CRLF & _
"fira" & @CRLF & _
"firar" & @CRLF & _
"firma" & @CRLF & _
"for" & @CRLF & _
"motiu" & @CRLF & _
"diomar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")