$re = '/(?=[diomarf]).*f.*/m';
$str = 'amfora
difamador
difamar
dimorf
dofi
fada
far
farao
farda
fiar
fiord
fira
firar
firma
for
motiu
diomar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);