import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[diomarf]).*f.*";
final String string = "amfora\n"
+ "difamador\n"
+ "difamar\n"
+ "dimorf\n"
+ "dofi\n"
+ "fada\n"
+ "far\n"
+ "farao\n"
+ "farda\n"
+ "fiar\n"
+ "fiord\n"
+ "fira\n"
+ "firar\n"
+ "firma\n"
+ "for\n"
+ "motiu\n"
+ "diomar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}