using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s)(?=(?:(?:[^""]*""[^""]*){2})*$)|\s(?!.*"")";
string input = @"hello and world or ""white fox"" ""or something"" like that";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}