re = /(\s)(?=(?:(?:[^"]*"[^"]*){2})*$)|\s(?!.*")/
str = 'hello and world or "white fox" "or something" like that'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end