$re = '/(\s)(?=(?:(?:[^"]*"[^"]*){2})*$)|\s(?!.*")/';
$str = 'hello and world or "white fox" "or something" like that';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);