using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[([\w\d\s]+\])([\w\d\s]+)\[\/\2)";
string input = @"Example text [hide] example hide text [/hide] pavelk.ru [shortcode] shortcodetext [/shortcode] happy end.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}