$re = '/(\[([\w\d\s]+\])([\w\d\s]+)\[\/\2)/i';
$str = 'Example text [hide] example hide text [/hide] pavelk.ru [shortcode] shortcodetext [/shortcode] happy end.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);