re = /(\[([\w\d\s]+\])([\w\d\s]+)\[\/\2)/i
str = 'Example text [hide] example hide text [/hide] pavelk.ru [shortcode] shortcodetext [/shortcode] happy end.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end