import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:[^\\n\\p{L}]*\\p{L}){4}[^\\n\\p{L}]*$)(?=(?:[^\\n\\p{N}]*\\p{N}){5,6}[^\\n\\p{N}]*$)(?=(?:[^\\n@]*@){3}[^\\n@]*$)[\\p{L}\\p{N} @]+$";
final String string = "@uuu111\n"
+ "@@@uuug11135\n"
+ "@@@uu1ug1113\n"
+ "@@@uu1ug11134\n"
+ "@@uu1ug11134\n"
+ "@@@uu1ug111f434";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}