const regex = /^(?=(?:[^\n\p{L}]*\p{L}){4}[^\n\p{L}]*$)(?=(?:[^\n\p{N}]*\p{N}){5,6}[^\n\p{N}]*$)(?=(?:[^\n@]*@){3}[^\n@]*$)[\p{L}\p{N} @]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:[^\\n\\p{L}]*\\p{L}){4}[^\\n\\p{L}]*$)(?=(?:[^\\n\\p{N}]*\\p{N}){5,6}[^\\n\\p{N}]*$)(?=(?:[^\\n@]*@){3}[^\\n@]*$)[\\p{L}\\p{N} @]+$', 'gm')
const str = `@uuu111
@@@uuug11135
@@@uu1ug1113
@@@uu1ug11134
@@uu1ug11134
@@@uu1ug111f434`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}