re = /^(?=(?:[^\n\p{L}]*\p{L}){4}[^\n\p{L}]*$)(?=(?:[^\n\p{N}]*\p{N}){5,6}[^\n\p{N}]*$)(?=(?:[^\n@]*@){3}[^\n@]*$)[\p{L}\p{N} @]+$/m
str = '@uuu111
@@@uuug11135
@@@uu1ug1113
@@@uu1ug11134
@@uu1ug11134
@@@uu1ug111f434'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end