import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:((\\babstract\\b\\s)?)(T\\s|\\w+<?\\w+<?\\w+>?>?\\s)(\\w+<T>|[a-zA-Z0-9]+)(\\(.*\\))(\\s=>\\s\\w+)?)";
final String string = "public void Something();\n"
+ "public List<int> SomethingElse();\n"
+ "private List<string> SomethingElseElse(One one);\n"
+ "private IEnumerable<List<string> Crazy(One one, Two two);\n"
+ "private IEnumerable<List<string> Crazy(One one, Two two) => AndSoOn;\n"
+ "public abstract void Run();\n"
+ "public T Get<T>(params object[] args)\n"
+ "private void rfrmBusyScreen_Load(object sender, EventArgs e)\n"
+ "public void Generate24HourSchedule(List<ScheduledEntry> scheduled)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}