const regex = /(?:((\babstract\b\s)?)(T\s|\w+<?\w+<?\w+>?>?\s)(\w+<T>|[a-zA-Z0-9]+)(\(.*\))(\s=>\s\w+)?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:((\\babstract\\b\\s)?)(T\\s|\\w+<?\\w+<?\\w+>?>?\\s)(\\w+<T>|[a-zA-Z0-9]+)(\\(.*\\))(\\s=>\\s\\w+)?)', 'g')
const str = `public void Something();
public List<int> SomethingElse();
private List<string> SomethingElseElse(One one);
private IEnumerable<List<string> Crazy(One one, Two two);
private IEnumerable<List<string> Crazy(One one, Two two) => AndSoOn;
public abstract void Run();
public T Get<T>(params object[] args)
private void rfrmBusyScreen_Load(object sender, EventArgs e)
public void Generate24HourSchedule(List<ScheduledEntry> scheduled)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}