# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:((\babstract\b\s)?)(T\s|\w+<?\w+<?\w+>?>?\s)(\w+<T>|[a-zA-Z0-9]+)(\(.*\))(\s=>\s\w+)?)"
test_str = ("public void Something();\n"
"public List<int> SomethingElse();\n"
"private List<string> SomethingElseElse(One one);\n"
"private IEnumerable<List<string> Crazy(One one, Two two);\n"
"private IEnumerable<List<string> Crazy(One one, Two two) => AndSoOn;\n"
"public abstract void Run();\n"
"public T Get<T>(params object[] args)\n"
"private void rfrmBusyScreen_Load(object sender, EventArgs e)\n"
"public void Generate24HourSchedule(List<ScheduledEntry> scheduled)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.