import re
regex = re.compile(r"-\s(.*)\n?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("- Abonnement Standard\n"
"- Support Standard\n"
"- 2 Canaux\n\n"
"- Définition de la stratégie de ciblage par un chef de produit dédié\n"
"- Suivi mensuel des performances et optimisation de la stratégie de ciblage \n"
"- Configuration et intégration\n"
"- Personnalisation de l'intégration graphique (2 allers-retours) - Option Responsive\n"
"- Formation à distance - 2 heures - 5 personnes\n"
"- Option Genius Targeting\n"
"- Option Genius Answers")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")