// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)-\s(.*)\n?").unwrap();
let string = "- Abonnement Standard
- Support Standard
- 2 Canaux
- Définition de la stratégie de ciblage par un chef de produit dédié
- Suivi mensuel des performances et optimisation de la stratégie de ciblage
- Configuration et intégration
- Personnalisation de l'intégration graphique (2 allers-retours) - Option Responsive
- Formation à distance - 2 heures - 5 personnes
- Option Genius Targeting
- Option Genius Answers";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}