import Foundation
let pattern = #"-\s(.*)\n?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
- Abonnement Standard
- Support Standard
- 2 Canaux
- Définition de la stratégie de ciblage par un chef de produit dédié
- Suivi mensuel des performances et optimisation de la stratégie de ciblage
- Configuration et intégration
- Personnalisation de l'intégration graphique (2 allers-retours) - Option Responsive
- Formation à distance - 2 heures - 5 personnes
- Option Genius Targeting
- Option Genius Answers
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)