import re
regex = re.compile(r"(<p.*?>.*?<\/p>)", flags=re.IGNORECASE)
test_str = "<p class=\"p\">test</p>"
subst = " "
result = regex.sub(subst, test_str, count=1)
if result:
print(result)