using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!|$|\"").*?)";
string input = @"@@doc.Register.Vertragsende@@!=null ? new DateTime({@@doc.Register.Vertragsende@@,@@doc.Register.WiedereinstellungszusageBis@@}.nonNull().max().Year, 12, 31) : null";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}