const regex = new RegExp('((?!|$|\\").*?)', '')
const str = `@@doc.Register.Vertragsende@@!=null ? new DateTime({@@doc.Register.Vertragsende@@,@@doc.Register.WiedereinstellungszusageBis@@}.nonNull().max().Year, 12, 31) : null`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}