$re = '@((?!|$|\").*?)@';
$str = '@@doc.Register.Vertragsende@@!=null ? new DateTime({@@doc.Register.Vertragsende@@,@@doc.Register.WiedereinstellungszusageBis@@}.nonNull().max().Year, 12, 31) : null';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);