const regex = new RegExp('^127\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}(\\:\\d+)?$', '')
const str = `127.1.1.1:4000
127.12.12.12
127.0.0.2:599595
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}