import re
regex = re.compile(r"^127\.\d{1,3}\.\d{1,3}\.\d{1,3}(\:\d+)?$")
test_str = ("127.1.1.1:4000\n"
"127.12.12.12\n"
"127.0.0.2:599595\n\n\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")