package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9a-f]{32}){1,2}`)
var str = `Success: Feed File Uploaded. Use the reference code afc3d6e84df84f51944a06cccee8f59a to track these records in the logs.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}