re = /([0-9a-f]{32}){1,2}/
str = 'Success: Feed File Uploaded. Use the reference code afc3d6e84df84f51944a06cccee8f59a to track these records in the logs.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end