const regex = /([0-9a-f]{32}){1,2}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9a-f]{32}){1,2}', '')
const str = `Success: Feed File Uploaded. Use the reference code afc3d6e84df84f51944a06cccee8f59a to track these records in the logs.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}