package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\t\n]*\t(?P<host_ip>[^\t]+)[^\t\n]*\t(?P<username>[a-z]+_[a-z]+)`)
var str = `Jan 21 14:42:20 10.0.0.0 user ssh 10.0.0.0 stop task_id=460864 service=shell priv-lvl=15 start_time=1453408940 timezone=UTC cmd=exit <cr>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}