#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(\d+)"
Local $sString = "http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158" & @CRLF & _
"http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158?page=2" & @CRLF & _
"http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158?page=2/" & @CRLF & _
"http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158Bombe" & @CRLF & _
"zeichenkette005415zeichenkette"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")