re = /\/(\d+)/m
str = 'http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158
http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158?page=2
http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158?page=2/
http://www.obi.de/baustoffhalle/category/Bedachungen_%26_Dachrinnen/1158Bombe
zeichenkette005415zeichenkette'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end