using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:(https?|ftp|file):\/\/|www\.|ftp\.)|([\w\-_]+(?:\.|\s*\[dot\]\s*[A-Z\-_]+)+))([A-Z\-\.,@?^=%&:\/~\+#]*[A-Z\-\@?^=%&\/~\+#]){2,6}?";
string input = @"Click w3.test.com/test
test 1.6 test
test 1.6test
Click www.testpage.com
Click2 no desktop.test.com
test https://stackoverflow.com/questions/60619430/cant-get-newest-data-from-dao-unless-restart-the-app
word word https://stackoverflow.com/questions/6038061/regular-expression-to-find-urls-within-a-string test";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}