use strict;
my $str = 'Click w3.test.com/test
test 1.6 test
test 1.6test
Click www.testpage.com
Click2 no desktop.test.com
test https://stackoverflow.com/questions/60619430/cant-get-newest-data-from-dao-unless-restart-the-app
word word https://stackoverflow.com/questions/6038061/regular-expression-to-find-urls-within-a-string test';
my $regex = qr/(?:(?:(https?|ftp|file):\/\/|www\.|ftp\.)|([\w\-_]+(?:\.|\s*\[dot\]\s*[A-Z\-_]+)+))([A-Z\-\.,@?^=%&:\/~\+#]*[A-Z\-\@?^=%&\/~\+#]){2,6}?/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}