const regex = /(?:(?:(https?|ftp|file):\/\/|www\.|ftp\.)|([\w\-_]+(?:\.|\s*\[dot\]\s*[A-Z\-_]+)+))([A-Z\-\.,@?^=%&:\/~\+#]*[A-Z\-\@?^=%&\/~\+#]){2,6}?/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:(https?|ftp|file):\\\/\\\/|www\\.|ftp\\.)|([\\w\\-_]+(?:\\.|\\s*\\[dot\\]\\s*[A-Z\\-_]+)+))([A-Z\\-\\.,@?^=%&:\\\/~\\+#]*[A-Z\\-\\@?^=%&\\\/~\\+#]){2,6}?', 'img')
const str = `Click w3.test.com/test
test 1.6 test
test 1.6test
Click www.testpage.com
Click2 no desktop.test.com
test https://stackoverflow.com/questions/60619430/cant-get-newest-data-from-dao-unless-restart-the-app
word word https://stackoverflow.com/questions/6038061/regular-expression-to-find-urls-within-a-string test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}