const regex = /(?<=Source IP03:)\s+((?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Source IP03:)\\s+((?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])\\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]))', '')
const str = `Source IP01: 1.1.1.1
Source IP02: 2.2.2.2 Source IP03: 3.3.3.3Source IP04: 2.2.2.2 Source IP05: 3.3.3.3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}