import Foundation
let pattern = #"(?<=Source IP03:)\s+((?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Source IP01: 1.1.1.1
Source IP02: 2.2.2.2 Source IP03: 3.3.3.3Source IP04: 2.2.2.2 Source IP05: 3.3.3.3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}