$re = '/(?<=Source IP03:)\s+((?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9][0-9]|[0-9]))/';
$str = 'Source IP01: 1.1.1.1
Source IP02: 2.2.2.2 Source IP03: 3.3.3.3Source IP04: 2.2.2.2 Source IP05: 3.3.3.3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);