import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\n"
+ "1111 1111\n\n"
+ "56822 554545 \n";
final String string = "1 00:00.0 11599,CLOSED\n"
+ "2 00:00.0 256,PENDING_PAYMENT\n"
+ "3 00:00.0 12111,COMPLETE\n"
+ "4 00:00.0 8827,CLOSED\n"
+ "5 00:00.0 11318,COMPLETE\n"
+ "6 00:00.0 7130,COMPLETE\n"
+ "7 00:00.0 4530,COMPLETE\n"
+ "8 00:00.0 2911,PROCESSING\n"
+ "9 00:00.0 5657,PENDING_PAYMENT\n"
+ "10 00:00.0 5648,PENDING_PAYMENT\n"
+ "11 00 918,PAYMENT_REVIEW\n"
+ "Sep 26 14:08:24 [creativebrs] OK LOGIN: Client \"45.63.237.2\"\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}