# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"\n"
r"1111 1111\n\n"
r"56822 554545 \n")
test_str = ("1 00:00.0 11599,CLOSED\n"
"2 00:00.0 256,PENDING_PAYMENT\n"
"3 00:00.0 12111,COMPLETE\n"
"4 00:00.0 8827,CLOSED\n"
"5 00:00.0 11318,COMPLETE\n"
"6 00:00.0 7130,COMPLETE\n"
"7 00:00.0 4530,COMPLETE\n"
"8 00:00.0 2911,PROCESSING\n"
"9 00:00.0 5657,PENDING_PAYMENT\n"
"10 00:00.0 5648,PENDING_PAYMENT\n"
"11 00 918,PAYMENT_REVIEW\n"
"Sep 26 14:08:24 [creativebrs] OK LOGIN: Client \"45.63.237.2\"\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.