package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\x00-\x7F]`)
var str = `2022-06-20 11:16:10,381 INFO [APP] log in : 38773763@#123@دالكي `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}