import Foundation
let pattern = #"^([1-9]{1}|(0[0-9]|1[0-2]))\/([1-9]{1}|0[1-9]|1\d|2\d|3[01])\/\d{4}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"12/31/1999"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}