$re = '/(\\\\ce(\{(?:[^{}]|(?-1))*?\}))/m';
$str = '\\displaystyle{\\ce{Cu^{2+}{(aq)}}+\\ce{Zn{(s)}}\\ce{->}\\ce{Cu_{(s)}}+\\ce{Zn^{2+}_{(aq)}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);